TS select second audio stream

TS select second audio stream

Postby quake505 » 08 Jun 2010, 18:06

Hi All,

I have been trying to convert a TS file using the second audio track, I have been using the -map command line command with no luck, I get the following error 'Error[ stream #0.3[0x76](eng): Subtitle: 0x0006Number of stream maps must match number of output streams'

Here is the file info: -

General
ID/String : 4
CompleteName : C:\movie.ts
Format : MPEG-TS
FileSize/String : 8.15 GiB
Duration/String : 1h 31mn
OverallBitRate/String : 12.7 Mbps

Video
ID/String : 48 (0x30)
MenuID/String : 137 (0x89)
Format : AVC
Format/Info : Advanced Video Codec
Format_Version : Version 2
Format_Profile : Main@L4.0
Format_Settings_CABAC/String : Yes
Format_Settings_RefFrames/String : 4 frame2
Duration/String : 1h 31mn
BitRate/String : 11.2 Mbps
Width/String : 1920 pixel3
Height/String : 1080 pixel3
DisplayAspectRatio/String : 16:9
FrameRate/String : 25.000 fps3
Resolution/String : 8 bit3
Colorimetry : 4:2:0
ScanType/String : Interlaced
ScanOrder/String : TFF
Bits-(Pixel*Frame) : 0.217
StreamSize/String : 7.22 GiB (88%)
colour_primaries : BT.709-5, BT.1361, IEC 61966-2-4, SMPTE RP177
transfer_characteristics : BT.709-5, BT.1361
matrix_coefficients : BT.709-5, BT.1361, IEC 61966-2-4 709, SMPTE RP177

Audio #1
ID/String : 64 (0x40)
MenuID/String : 137 (0x89)
Format : MPEG Audio
Format_Version : Version 1
Format_Profile : Layer 2
Duration/String : 1h 31mn
BitRate_Mode/String : CBR
BitRate/String : 192 Kbps
Channel(s)/String : 2 channel2
SamplingRate/String : 48.0 KHz
Video_Delay/String : -1s 579ms
StreamSize/String : 126 MiB (2%)
Language/String : nar

Audio #2
ID/String : 65 (0x41)
MenuID/String : 137 (0x89)
Format : AC-3
Format/Info : Audio Coding 3
Duration/String : 1h 31mn
BitRate_Mode/String : CBR
BitRate/String : 384 Kbps
Channel(s)/String : 5 channel3
ChannelPositions : Front: L C R, Surround: L R
SamplingRate/String : 48.0 KHz
Video_Delay/String : -1s 544ms
StreamSize/String : 253 MiB (3%)
Language/String : en

Text
ID/String : 118 (0x76)
MenuID/String : 137 (0x89)
Format : Teletext
Language/String : en



XP Service Pack 3,Pro 32 bits Execution
C:\Program Files\QuickMediaConverter
C:\Program Files\QuickMediaConverter\QMC.exe
4.0.0.20 32 bits


The error seems to be linked to the Teletext stream (0x76).

I have tried the following map commands: -

-map 0:2
-map 0:41
-map 0:65
-map 48:65
-map 30:41
-map 0x30:0x41
-map 0:1

All give me the same error, if I don't use the -map command the file converts with the first audio track, which is music sound track only.

Been looking around but can't find much info on the map command.

Hope you can help.

Quake505
quake505
 
Posts: 2
Joined: 08 Jun 2010, 17:45

Re: TS select second audio stream

Postby quake505 » 11 Jun 2010, 13:47

Hi All,

I have resolved this, what I didn't understand is that I need a map command for both the video and audio, so I needed -map 0:0 -map0:2.

It would be nice if QMC showed the stream id so it can be mapped easier.

Later Q505
quake505
 
Posts: 2
Joined: 08 Jun 2010, 17:45

Re: TS select second audio stream

Postby Cocoon-Dev » 13 Jun 2010, 12:11

Hello,

we working for a future release on this subject.

Now you can find more information on the http://www.ffmepg.org website.

But it's just , to map the good audio file you must in first select the option info file so you can view the details on the audio's and the subtitle's included in the video and then use in command line the good mapping instruction with -map and the number of mapping.

Thank you for your support.

have a nice day.
thx for donating
http://www.cocoonsoftware.com/paypaldonate-us.htm
Team Cocoon
User avatar
Cocoon-Dev
Site Admin
 
Posts: 1123
Joined: 24 Sep 2007, 00:54


Return to Expert Users Mode

Who is online

Users browsing this forum: No registered users and 1 guest

cron