problème de langage après la conversion

Forum rules
A lire Absolument avant de poser votre question!
Merci de lire ceci avant de poster
loock16
Posts: 6
Joined: 07 Mar 2010, 20:43

problème de langage après la conversion

Postby loock16 » 07 Mar 2010, 21:01

Bonjour,

j'ai décodé un film d'un format mkv au format dvd.
le décodage s'est très bien déroulé jusqu'a la fin ou j'ai eu un message d'erreur sur le signal audio; résultat j'ai une super image et un super son sauf que l'audio est en anglais.
j'ai vu sur un autre topic que c'est déja arrivé sur des versions antérieurs de QMC et apparement je n'ai pas le même soucis.

j'utilise la version 4.0.0.8 de QMC sur windows 7 home édition 64bits
voici les détails du fichier que je souhaite décoder.

General
CompleteName : D:\Videos\Twilight.1080p.mkv
Format : Matroska
FileSize/String : 9.02 GiB
Duration/String : 2h 1mn
OverallBitRate/String : 10.6 Mbps
Encoded_Date : UTC 2009-03-10 20:24:10
Encoded_Application : mkvmerge v2.0.2 ('You're My Flame') built on Feb 21 2007 23:40:55
Encoded_Library/String : libebml v0.7.7 + libmatroska v0.8.1

Video
ID/String : 1
Format : AVC
Format/Info : Advanced Video Codec
Format_Profile : High@L4.1
Format_Settings_CABAC/String : Yes
Format_Settings_RefFrames/String : 5 frame3
MuxingMode : Container profile=Unknown@4.1
CodecID : V_MPEG4/ISO/AVC
Duration/String : 2h 1mn
BitRate/String : 8236 Kbps
BitRate_Nominal/String : 8443 Kbps
Width/String : 1920 pixel3
Height/String : 800 pixel3
DisplayAspectRatio/String : 2.40:1
FrameRate/String : 23.976 fps2
Resolution/String : 8 bit3
Colorimetry : 4:2:0
ScanType/String : Progressive
Bits-(Pixel*Frame) : 0.224
StreamSize/String : 7.00 GiB (78%)
Encoded_Library/String : x264 core 67 r1125M 10d6ef0
Encoded_Library_Settings : cabac=1 / ref=5 / deblock=1:0:0 / analyse=0x3:0x133 / me=umh / subme=7 / psy_rd=1.0:0.0 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / chroma_qp_offset=-2 / threads=6 / nr=0 / decimate=1 / mbaff=0 / bframes=3 / b_pyramid=1 / b_adapt=1 / b_bias=0 / direct=1 / wpredb=1 / keyint=250 / keyint_min=25 / scenecut=40 / rc=2pass / bitrate=8443 / ratetol=1.0 / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / pb_ratio=1.30 / aq=1:1.00
Language/String : en

Audio #1
ID/String : 2
Format : DTS
Format/Info : Digital Theater Systems
CodecID : A_DTS
Duration/String : 2h 1mn
BitRate_Mode/String : CBR
BitRate/String : 1510 Kbps
Channel(s)/String : 6 channel3
ChannelPositions : Front: L C R, Surround: L R, LFE
SamplingRate/String : 48.0 KHz
Resolution/String : 24 bit2
StreamSize/String : 1.28 GiB (14%)
Title : DTS
Language/String : en

Audio #2
ID/String : 3
Format : AC-3
Format/Info : Audio Coding 3
CodecID : A_AC3
Duration/String : 2h 1mn
BitRate_Mode/String : CBR
BitRate/String : 640 Kbps
Channel(s)/String : 6 channel3
ChannelPositions : Front: L C R, Surround: L R, LFE
SamplingRate/String : 48.0 KHz
StreamSize/String : 558 MiB (6%)
Title : 5.1
Language/String : fr

Text #1
ID/String : 4
Format : UTF-8
CodecID : S_TEXT/UTF8
CodecID/Info : UTF-8 Plain Text
Language/String : en

Text #2
ID/String : 5
Format : UTF-8
CodecID : S_TEXT/UTF8
CodecID/Info : UTF-8 Plain Text
Language/String : fr



7 Home Edition,64 Execution en 64 bits
F:
F:\QMC.exe
4.0.0.8 32 bits



En attente de votre réponse
Loock16
User avatar
Cocoon-Dev
Site Admin
Posts: 1150
Joined: 24 Sep 2007, 00:54

Re: problème de langage après la conversion

Postby Cocoon-Dev » 09 Mar 2010, 07:02

Bonjour,

merci de supporter QMC.

Comme je vois dans les infos du fichier cela vient du fait que l'anglais est par défaut en 1 dans le stream audio, voir ci-dessous.
Le mieux est de passer en mode expert et de faire un map de l'audio 2.
Voici une petite explication pour vous aider.

* Vous pouvez encoder plusieurs formats en même temps et de définir une
mappage à partir de flux d'entrée vers les flux de sortie: ffmpeg-i / tmp / a.wav-AB 64 / tmp/a.mp2-ab 128 / tmp/b.mp2 -map midi 0:0 -map midi 0:0

1-Convertir a.wav à a.mp2 à 64 kbits et b.mp2 à 128 Kbits.
2-file: index 'spécifier que les flux d'entrée sont utilisés pour chaque sortie
+ Convertit a.wav à a.mp2 à 64 kbits et à b.mp2 à 128 Kbits.
+ fichier: index 'spécifie les flux d'entrée utilisés pour chaque sortie dans un ordre définit lors de la production du flux.

Audio #1
ID/String : 2
Format : DTS
Format/Info : Digital Theater Systems
CodecID : A_DTS
Duration/String : 2h 1mn
BitRate_Mode/String : CBR
BitRate/String : 1510 Kbps
Channel(s)/String : 6 channel3
ChannelPositions : Front: L C R, Surround: L R, LFE
SamplingRate/String : 48.0 KHz
Resolution/String : 24 bit2
StreamSize/String : 1.28 GiB (14%)
Title : DTS
Language/String : en

Audio #2
ID/String : 3
Format : AC-3
Format/Info : Audio Coding 3
CodecID : A_AC3
Duration/String : 2h 1mn
BitRate_Mode/String : CBR
BitRate/String : 640 Kbps
Channel(s)/String : 6 channel3
ChannelPositions : Front: L C R, Surround: L R, LFE
SamplingRate/String : 48.0 KHz
StreamSize/String : 558 MiB (6%)
Title : 5.1
Language/String : fr

Pour vous mettre déjà sur la bonne voie, il existe un profil MKV en mode expert :)


Bonne journée.
thx for donating
http://www.cocoonsoftware.com/paypaldonate-us.htm
Team Cocoon
loock16
Posts: 6
Joined: 07 Mar 2010, 20:43

Re: problème de langage après la conversion

Postby loock16 » 09 Mar 2010, 11:16

Bonjour et merci pour ces explications

par contre je suis pas un as de l'encodage donc j'ai rien compris (désolé)

pouvez vous me simplifiez l'explication ou m'envoyer un message avec ce qu'il faut rentrer dans chaque case en mode expert.

merci d'avance et a bientot
User avatar
Cocoon-Dev
Site Admin
Posts: 1150
Joined: 24 Sep 2007, 00:54

Re: problème de langage après la conversion

Postby Cocoon-Dev » 11 Mar 2010, 01:21

Bonjour,

correction.

Prenez dans votre cas un profil "DVD" et écrire dans la ligne de commande de l'onglet vidéo du mode expert " map 0:3 " avec un espace devant et derrière pour mapper le français.

Bonne journée.
thx for donating
http://www.cocoonsoftware.com/paypaldonate-us.htm
Team Cocoon
loock16
Posts: 6
Joined: 07 Mar 2010, 20:43

Re: problème de langage après la conversion

Postby loock16 » 11 Mar 2010, 20:47

Bonjour,

merci pour cette correction mais ça ne fonctionne toujours pas

quand je charge le modèle DVD j'ai cette phrase dans la barre commande : " -target ntsc-dvd -mbd rd -cmp 2 -subcmp 2 "
si je remplace tout ça ne fonctionne pas, si je complète par " map 0:3 " ça ne fonctionne pas non plus; à chaque fois l'encodage échoue avec un message d'erreur.

dans le 1er cas voici le message d'erreur obtenu : Erreur [ Stream #0.4(fre): Subtitle: 0x0000Number of stream maps must match number of output streams]

dans le 2e cas j'obtiens :Erreur [ Stream #0.4(fre): Subtitle: 0x0000File 'map' already exists. Overwrite ? [y/N] Not overwriting - exiting]

je sais pas quoi faire là....

j'attend votre réponse
User avatar
Cocoon-Dev
Site Admin
Posts: 1150
Joined: 24 Sep 2007, 00:54

Re: problème de langage après la conversion

Postby Cocoon-Dev » 12 Mar 2010, 07:23

Bonjour,

remplacez " map 0:3 " par " map 0:4 "
Sinon envoye moi un lien ou je pex prendre votre video et faire un test.


Bien a vous.

Bonne journee.
thx for donating
http://www.cocoonsoftware.com/paypaldonate-us.htm
Team Cocoon
loock16
Posts: 6
Joined: 07 Mar 2010, 20:43

Re: problème de langage après la conversion

Postby loock16 » 12 Mar 2010, 12:13

bonjour,

j'obtiens toujours les même messages d'erreurs avec " map 0:4 ". je fais peut etre une mauvaise manipulation.

je veux bien envoyer le lien pour le fichier mais il est très long a telecharger ( 9Go) donc je sais pas si çà vaut le coup.
par contre pour info j'ai encoder un autre film de mkv à dvd et je n'ai pas eu de problèmes.

et encore merci pour votre aide.
User avatar
Cocoon-Dev
Site Admin
Posts: 1150
Joined: 24 Sep 2007, 00:54

Re: problème de langage après la conversion

Postby Cocoon-Dev » 13 Mar 2010, 07:49

Bojour,

envoyez-moi le debut de votre video.

Cela sera suffisant pour vous donnez la bonne commande...


Bonne journee.
thx for donating
http://www.cocoonsoftware.com/paypaldonate-us.htm
Team Cocoon
loock16
Posts: 6
Joined: 07 Mar 2010, 20:43

Re: problème de langage après la conversion

Postby loock16 » 13 Mar 2010, 21:53

Bonjour,

voici le lien pour telecharger le film

http://www.emule-island.com/telecharger ... 14232.divx

j'ai essayé de couper le film avec plusieurs logiciels mais aucun ne prend en compte le format mkv. comment je peux faire je sais pas si QMC peut le faire.
seul vlc permet un enregistrement du film mais les paramètres du fichier obtenu ne correspondent pas au fichier en .mkv donc je pense pas que cà aide beaucoup.

comment faire ????

a bientot
User avatar
Cocoon-Dev
Site Admin
Posts: 1150
Joined: 24 Sep 2007, 00:54

Re: problème de langage après la conversion

Postby Cocoon-Dev » 15 Mar 2010, 00:42

Bonsoir,

je vais prendre une partie et voir cela.

Bonne soiree.
thx for donating
http://www.cocoonsoftware.com/paypaldonate-us.htm
Team Cocoon
loock16
Posts: 6
Joined: 07 Mar 2010, 20:43

Re: problème de langage après la conversion

Postby loock16 » 30 Mar 2010, 18:29

Bonjour,

juste un message pour savoir si vous avez trouvé une solution

a bientot
User avatar
Cocoon-Dev
Site Admin
Posts: 1150
Joined: 24 Sep 2007, 00:54

Re: problème de langage après la conversion

Postby Cocoon-Dev » 06 Apr 2010, 01:19

Bonsoir,

il faut aller en mode expert et sélectionner le profil dvd et choisir libmp3lame pour faire le test.
Mettre en ligne de commande ce qui suit : *map 0:3 (piste audio francaise)

Bonne soirée.
thx for donating
http://www.cocoonsoftware.com/paypaldonate-us.htm
Team Cocoon

Return to “Video”

Who is online

Users browsing this forum: No registered users and 1 guest