audio language when converting

swaimdc
Posts: 1
Joined: 13 Aug 2009, 15:06

audio language when converting

Postby swaimdc » 13 Aug 2009, 20:40

I have searched the Forum regarding my question and found nothing relating to it.
I am trying to convert a VOB to an AVI using QMC. Using VLC Media Player, I can choose which language I want (English) by going to Audio Track and selecting which one I want [see screen shot]
VOB #1.jpg
VOB showing Audio Track possible selections
VOB #1.jpg (26.15 KiB) Viewed 6822 times


After I convert the VOB to an AVI with QMC, using VLC there is only 1 Audio Track choice. This is not English, but is French in this example [see screen shot]
AVI converted by QMC.jpg
AVI showing only 1 Video Track Choice
AVI converted by QMC.jpg (22.48 KiB) Viewed 6819 times



Here is the info on this VOB taken from QMC:

General
CompleteName : K:\DVDs\FullDisc\ENTOURAGE_S5_D2\VIDEO_TS\VTS_01_1.VOB
Format : MPEG-PS
FileSize/String : 1 Config_Text_ThousandsSeparator024 MiB
Duration/String : 18mn 4s
OverallBitRate/String : 7 Config_Text_ThousandsSeparator924 Kbps

Video
Format : MPEG Video
Format_Version : Version 2
Format_Profile : Main@Main
Format_Settings_Matrix/String : Standard
Duration/String : 18mn 3s
BitRate_Mode/String : CBR
BitRate/String : 6 Config_Text_ThousandsSeparator219 Kbps
BitRate_Nominal/String : 7 Config_Text_ThousandsSeparator500 Kbps
Width/String : 720 pixel3
Height/String : 480 pixel3
DisplayAspectRatio/String : 16/9
FrameRate/String : 29 Config_Text_FloatSeparator970 fps3
Standard : NTSC
Colorimetry : 4:2:0
ScanType/String : Interlaced
ScanOrder/String : TFF
Bits-(Pixel*Frame) : 0.724

Audio Config_Text_NumberTag1
Format : AC-3
Format/Info : Audio Coding 3
Duration/String : 18mn 4s
BitRate_Mode/String : CBR
BitRate/String : 384 Kbps
Channel(s)/String : 6 channel3
ChannelPositions : Front: L C R, Rear: L R, LFE
SamplingRate/String : 48 Config_Text_FloatSeparator0 KHz
Video_Delay/String : -67ms

Audio Config_Text_NumberTag2
Format : AC-3
Format/Info : Audio Coding 3
Duration/String : 18mn 4s
BitRate_Mode/String : CBR
BitRate/String : 384 Kbps
Channel(s)/String : 6 channel3
ChannelPositions : Front: L C R, Rear: L R, LFE
SamplingRate/String : 48 Config_Text_FloatSeparator0 KHz
Video_Delay/String : -67ms

Audio Config_Text_NumberTag3
Format : AC-3
Format/Info : Audio Coding 3
Format_Profile : Dolby Digital
Duration/String : 18mn 4s
BitRate_Mode/String : CBR
BitRate/String : 192 Kbps
Channel(s)/String : 2 channel2
ChannelPositions : L R
SamplingRate/String : 48 Config_Text_FloatSeparator0 KHz
Video_Delay/String : -67ms

Audio Config_Text_NumberTag4
Format : AC-3
Format/Info : Audio Coding 3
Format_Profile : Dolby Digital
Duration/String : 18mn 4s
BitRate_Mode/String : CBR
BitRate/String : 192 Kbps
Channel(s)/String : 2 channel2
ChannelPositions : L R
SamplingRate/String : 48 Config_Text_FloatSeparator0 KHz
Video_Delay/String : -50ms

Text Config_Text_NumberTag1
Format : RLE
Format/Info : Run-length encoding
Video_Delay/String : 18mn 1s

Text Config_Text_NumberTag2
Format : RLE
Format/Info : Run-length encoding
Video_Delay/String : 18mn 1s

Text Config_Text_NumberTag3
Format : RLE
Format/Info : Run-length encoding
Video_Delay/String : 18mn 1s

Menu
Format : DVD-Video


Do you have any http://www.cocoonsoftware.com/paypaldonate-us.htm on how to either bring all viideo tracks over with the conversion or to indicate which audio track I wish to be converted with the video?

Thanks,

Robin
User avatar
Cocoon-Dev
Site Admin
Posts: 1152
Joined: 24 Sep 2007, 00:54

Re: audio language when converting

Postby Cocoon-Dev » 17 Aug 2009, 21:30

Hello swaimdc,
in your case the first language is french, your video file have more than one language and Qmc map by default the first language in the video.
Now you can go in expert mode and use the following process to use the good language :
1. Load the profil sended in this post on your desktop.
2. Open QMC and go to Expert Mode ( click Expert in the icon menu).
3.Click on the button "Load profil" and select the profil loaded on your desktop.
3. The following string in the field "cmd" give you the language to select in the conversion : -map 0:0 -map 0:2

A little explanation -map 0:0 the video file and -map 0:2 tha audio file thus in your case,try with -map 0:3 or -map 0:4 if -map 0:2 is not good.

Now for more information, you can follow the video training on the website at the following address : http://www.cocoonsoftware.com/index.php?option=com_content&task=view&id=106&Itemid=69

Have a nice day.
Attachments
Dvd with map lang.xml
Profil for language mapping dvd conversion
(1.14 KiB) Downloaded 93 times
thx for donating
http://www.cocoonsoftware.com/paypaldonate-us.htm
Team Cocoon

Return to “Audio Related”

Who is online

Users browsing this forum: No registered users and 2 guests