Sound Sync Problem.

john-z
Posts: 4
Joined: 23 Mar 2009, 23:41

Sound Sync Problem.

Postby john-z » 24 Mar 2009, 00:13

I am using QMC 3.6.5. with Windows XP Pro. I converted two .avi files to DVD (.mpg) with the easy mode, NTSC HQ 16:9

Both files converted, but for one the sound is not in sync with the video just off by a second or less). I will include the information from both files. Any help will be appreciated

Here is the information on the file that did NOT work.
CompleteName : C:\myvideos\Bolt.avi
Format : AVI
Format/Info : Audio Video Interleave
FileSize/String : 701 MiB
Duration/String : 1h 36mn
OverallBitRate/String : 1 Config_Text_ThousandsSeparator018 Kbps
Encoded_Application : VirtualDubMod 1.5.10.1 (build 2366/release)
Encoded_Library/String : VirtualDubMod build 2366/release

Video
Format : MPEG-4 Visual
Format_Profile : Streaming Video@L1
Format_Settings_BVOP/String : Yes
Format_Settings_QPel/String : No
Format_Settings_GMC/String : warppoint0
Format_Settings_Matrix/String : Default
CodecID : DX50
CodecID/Hint : DivX 5
Duration/String : 1h 36mn
BitRate/String : 880 Kbps
Width/String : 636 pixel3
Height/String : 346 pixel3
DisplayAspectRatio/String : 16/9
FrameRate/String : 23 Config_Text_FloatSeparator976 fps3
Resolution/String : 24 bit3
Colorimetry : 4:2:0
ScanType/String : Progressive
Bits-(Pixel*Frame) : 0.167
StreamSize/String : 607 MiB (87%)
Encoded_Library/String : XviD 1.0.3 (UTC 2004-12-20)

Audio
Format : MPEG Audio
Format_Version : Version 1
Format_Profile : Layer 3
CodecID : 55
CodecID/Hint : MP3
Duration/String : 1h 36mn
BitRate_Mode/String : CBR
BitRate/String : 128 Kbps
Channel(s)/String : 2 channel2
SamplingRate/String : 48 Config_Text_FloatSeparator0 KHz
Resolution/String : 16 bit3
Video_Delay/String : 480ms
StreamSize/String : 88 Config_Text_FloatSeparator2 MiB (13%)
Alignment/String : Alignment_Aligned
Interleave_Duration/String : 42 ms (1 Config_Text_FloatSeparator00 video frames1)
Interleave_Preload/String : 504 ms


Here is the information on the file that DID work

General
CompleteName : C:\myvideos\National Treasure 2-Book Of Secrets.avi
Format : AVI
Format/Info : Audio Video Interleave
FileSize/String : 701 MiB
Duration/String : 2h 4mn
OverallBitRate/String : 787 Kbps
Encoded_Application : VirtualDubMod 1.5.10.1 (build 2366/release)
Encoded_Library/String : VirtualDubMod build 2366/release

Video
Format : MPEG-4 Visual
Format_Profile : Streaming Video@L1
Format_Settings_BVOP/String : Yes
Format_Settings_QPel/String : No
Format_Settings_GMC/String : warppoint0
Format_Settings_Matrix/String : Default
CodecID : DX50
CodecID/Hint : DivX 5
Duration/String : 2h 4mn
BitRate/String : 682 Kbps
Width/String : 632 pixel3
Height/String : 258 pixel3
DisplayAspectRatio/String : 2.450
FrameRate/String : 23 Config_Text_FloatSeparator976 fps3
Resolution/String : 24 bit3
Colorimetry : 4:2:0
ScanType/String : Progressive
Bits-(Pixel*Frame) : 0.174
StreamSize/String : 608 MiB (87%)
Encoded_Library/String : XviD 1.0.3 (UTC 2004-12-20)

Audio
Format : MPEG Audio
Format_Version : Version 1
Format_Profile : Layer 3
CodecID : 55
CodecID/Hint : MP3
Duration/String : 2h 4mn
BitRate_Mode/String : CBR
BitRate/String : 96 Config_Text_FloatSeparator0 Kbps
Channel(s)/String : 2 channel2
SamplingRate/String : 48 Config_Text_FloatSeparator0 KHz
Resolution/String : 16 bit3
StreamSize/String : 85 Config_Text_FloatSeparator5 MiB (12%)
Alignment/String : Alignment_Aligned
Interleave_Duration/String : 42 ms (1 Config_Text_FloatSeparator00 video frames1)
Interleave_Preload/String : 504 ms
User avatar
Cocoon-Dev
Site Admin
Posts: 1152
Joined: 24 Sep 2007, 00:54

Re: Sound Sync Problem.

Postby Cocoon-Dev » 24 Mar 2009, 06:45

Hello,

ffmpeg don't support video converted with VirtualDubMod and this programm give always a sync problem with audio.
It is not the first time...

Have a nice day.
thx for donating
http://www.cocoonsoftware.com/paypaldonate-us.htm
Team Cocoon
john-z
Posts: 4
Joined: 23 Mar 2009, 23:41

Re: Sound Sync Problem.

Postby john-z » 24 Mar 2009, 14:19

Both files were converted with the same version of VirtualDub so I don't think that is the problem.

The file with sound problems has a line in the audio section that says "delay time". Is that where the problem is?
User avatar
Cocoon-Dev
Site Admin
Posts: 1152
Joined: 24 Sep 2007, 00:54

Re: Sound Sync Problem.

Postby Cocoon-Dev » 24 Mar 2009, 21:03

hello,

just find.
Problem come from delay inserted by virtualdub.

Have a nice day.
thx for donating
http://www.cocoonsoftware.com/paypaldonate-us.htm
Team Cocoon
john-z
Posts: 4
Joined: 23 Mar 2009, 23:41

Re: Sound Sync Problem.

Postby john-z » 24 Mar 2009, 21:57

Can I edit the delay or have QMC correct for it? The .AVI file plays perfectly, there is no trouble with the sound until I convert to .MPG with CUC.
User avatar
Cocoon-Dev
Site Admin
Posts: 1152
Joined: 24 Sep 2007, 00:54

Re: Sound Sync Problem.

Postby Cocoon-Dev » 29 Mar 2009, 13:29

Yes if you want.

Now, you need to have a good knowledge in ffmpeg command to play in expert mode.
You can try in expert mode with the following command in command line : -ss time_off or -itsoffset time_off with an integer value..

have a nice day
thx for donating
http://www.cocoonsoftware.com/paypaldonate-us.htm
Team Cocoon

Return to “Audio Related”

Who is online

Users browsing this forum: No registered users and 1 guest